Page tree
Skip to end of metadata
Go to start of metadata

Consulte a documentação de seu sistema de gestão para informações dos sistemas operacionais homologados para a linha de produto.

Os sistemas operacionais homologados somente suportam o range de caracteres ocidentais.

Em builds iguais ou superiores à 170117 não é aconselhado o uso do SmartClient via compartilhamento de rede, devido ao grande conjunto de arquivos que compõe o produto.

O uso em compartilhamento de rede, apesar de operacional, poderá causar atraso na carga da aplicação inicial e das telas que contenham conteúdo HTML.

Dê preferência à uma instalação local do SmartClient, utilizando nosso ferramental de update automático para sua atualização/manutenção. Mais informações acesse aqui.


Não homologado

O uso de metaframes (web enablers), como Citrix e Remote Desktop Services (Terminal Services), para a republicação de aplicações não é homologado, porém suportado para uso.

  • Homologado: Testado oficialmente e certificado para uso, temos que garantir funcionamento e comportamento
  • Suportado: Não testado, porém funcional, podendo haver eventuais comportamentos não previstos

Fabricante

Sistema Operacional

Observações

Status

Apple
Resultado de imagem para logo apple 2020 png

macOS 10.15 Catalina

(info) Homologado para build igual ou superior a 7.00.170117A-20190903.

SUPPORTED


macOS 10.14 Mojave

(info) Homologado para build igual ou superior a 7.00.1312271A-20180928.

SUPPORTED


macOS 10.13 High Sierra(info) Homologado para build igual ou superior a 7.00.131227A-20171025.

EOL





Microsoft
Resultado de imagem para logo windows 10

Windows 10 Enterprise(info) Homologado para build igual ou superior a 7.00.131227A-20150625.

SUPPORTED


Windows 10 Pro(info) Homologado para build igual ou superior a 7.00.131227A-20150625.

SUPPORTED


Windows 8.1 Enterprise

(info) Homologado para build igual ou superior a 7.00.131227A-20140829.

Importante:  Sistema operacional em suporte estendido, mais informações acesse este link.

EOL

Windows 8.1 Pro

(info) Homologado para build igual ou superior a 7.00.131227A-20140829.

Importante:  Sistema operacional em suporte estendido, mais informações acesse este link.

EOL

Windows 7 Enterprise

(error) Suporte encerrado pelo fabricante em 14 de janeiro de 2020

   (error) Não compatível com build superior a 7.00.131227A

UNSUPPORTED


Windows 7 Professional

(error) Suporte encerrado pelo fabricante em 14 de janeiro de 2020

   (error) Não compatível com build superior a 7.00.131227A

UNSUPPORTED


Windows XP Professional

(error) Suporte encerrado pelo fabricante em 20 de abril de 2019

   (error) Não compatível com build superior a 7.00.131227A

UNSUPPORTED





Red Hat
Resultado de imagem para logo redhat

Red Hat Enterprise Linux Desktop 7.3 64 bits

*Ler adendo ao lado.

(info) Homologado para build igual ou superior a 7.00.131227A-20160820 e build inferior 7.00.191205P .

(error) Acesso root (sudo) não permitido para build igual ou superior a 7.00.191205P-20191205. (UNIX_ROOT)

(info) Adendo Importante:
Para mantermos compatibilização com os pacotes/bibliotecas mais atuais de mercado, à partir da build 7.00.170117A-20190903 o SmartClient será gerado exclusivamente para arquitetura 64 bits, não sendo mais compatível com versões 32 bits do Linux.

SUPPORTED


Red Hat Enterprise Linux Desktop 8.0 64 bits

*Ler adendo ao lado.

(info) Homologado para build igual ou superior a 7.00.191205P-20191205

(info) Adendo Importante:
Para mantermos compatibilização com os pacotes/bibliotecas mais atuais de mercado, à partir da build 7.00.170117A-20190903 o SmartClient será gerado exclusivamente para arquitetura 64 bits, não sendo mais compatível com versões 32 bits do Linux.

(info) Pré-requisitos para uso do Sistema Operacional 

  • libstdc++ 3.4.21 ou superior
  • libXScrnSaver - X11 Screen Saver extension client library, podendo ser instalado a partir do comando:
    sudo yum install libXScrnSaver 

(error) Acesso root (sudo) não permitido para build igual ou superior a 7.00.191205P-20191205. (UNIX_ROOT)

SUPPORTED





SUSE
Resultado de imagem para logo suse

SUSE Linux Enterprise Desktop 12 SP2 64 bits

*Ler adendo ao lado.

(error) Suporte descontinuado pelo fabricante do software.

(error) Acesso root (sudo) não permitido para build igual ou superior a 7.00.191205P-20191205. (UNIX_ROOT)

(info) Adendo Importante:
Para mantermos compatibilização com os pacotes/bibliotecas mais atuais de mercado, à partir da build 7.00.170117A-20190903 o SmartClient será gerado exclusivamente para arquitetura 64 bits, não sendo mais compatível com versões 32 bits do Linux.

UNSUPPORTED


SUSE Linux Enterprise Desktop 12 SP4 64 bits

*Ler adendo ao lado.

(info) Homologado para build igual ou superior a 7.00.191205P-20191205

(error) Acesso root (sudo) não permitido para build igual ou superior a 7.00.191205P-20191205. (UNIX_ROOT)

(info) Adendo Importante:
Para mantermos compatibilização com os pacotes/bibliotecas mais atuais de mercado, à partir da build 7.00.170117A-20190903 o SmartClient será gerado exclusivamente para arquitetura 64 bits, não sendo mais compatível com versões 32 bits do Linux.

SUPPORTED





Ubuntu

Ubuntu 16.04 LTS Desktop 32/64 bits

*Ler adendo ao lado.

(info) Homologado para build igual ou superior a 7.00.131227A-20170626.

(info) Adendo Importante:
O Ubuntu 16.04 foi a ultima versão a manter uma distribuição para arquitetura 32 bits. Para mantermos compatibilização com os pacotes/bibliotecas mais atuais de mercado, à partir da build 7.00.170117A-20190903 o SmartClient será gerado exclusivamente para arquitetura 64 bits, não sendo mais compatível com a versão 32 desta distro em questão.

(error) Acesso root (sudo) não permitido para build igual ou superior a 7.00.191205P-20191205. (UNIX_ROOT)

SUPPORTED


Ubuntu 18.04 LTS Desktop 64 bits


*Ler adendo ao lado.

(info) Homologado para build igual ou superior a 7.00.170117A-20190903.

(info) Adendo Importante:
A partir do Ubuntu 18.04 deixou de ser expedida a versão para arquitetura 32 bits. Para mantermos compatibilização com os pacotes/bibliotecas mais atuais de mercado, à partir da build 7.00.170117A-20190903 o SmartClient será gerado exclusivamente para arquitetura 64 bits.

(error) Acesso root (sudo) não permitido para build igual ou superior a 7.00.191205P-20191205. (UNIX_ROOT)

SUPPORTED